-
Partition problem: "Error: expected at least 7 tokens..
Trying to install double-boot with preinstalled Win xp, 250 GB mirror HDD . Current partition (with Partition magic):
50 MB - FAT (Dellutilities) primary, 160GB - NTFS primary, 20 GB - FAT32 logical, ~70 GB - unallocated.
Then I started knx-hdinstall (v 3.3) and got the following after a second dialogue window:
"Error: expected at least 7 tokens for --radiolist, have 5".
Prepartitioning (again with Partition magic) of the empty space as ex2 or ex3 and extra swap partition does not help. cfdisk results in "FATAL ERROR: connot open disk drive" ...
Knoppix runs well from a CD.
What is wrong with this partition and/or installation?
-
Senior Member
registered user
Re: Partition problem: "Error: expected at least 7 toke

Originally Posted by
palex
Trying to install double-boot with preinstalled Win xp, 250 GB mirror HDD . Current partition (with Partition magic):
50 MB - FAT (Dellutilities) primary, 160GB - NTFS primary, 20 GB - FAT32 logical, ~70 GB - unallocated.
Then I started knx-hdinstall (v 3.3) and got the following after a second dialogue window:
"Error: expected at least 7 tokens for --radiolist, have 5".
That's an error from the installer itself. Are you runing the installer from X or run level 2? Try whichever one you've not yet tried. Of course it would be a good idea to get the latest Knoppix if you can.
To get run level 2 at the boot: type
knoppix 2
Prepartitioning (again with Partition magic) of the empty space as ex2 or ex3 and extra swap partition does not help.
Prepartitionig as ext2 or ext3? This makes no sense to me. You cannot partition as ext2 or ext3. You create a partition then you put a filesystem on it. These are two different things.
What is wrong with this partition and/or installation?
From what I've read (nope haven't tried it myself) PM is anything but magic but it does appear to be quite good at hosing up partition tables. Anyway....
cfdisk results in "FATAL ERROR: connot open disk drive" ...
Knoppix runs well from a CD.
Are you running cfdisk as root?
Code:
sudo cfdisk /dev/hda
-
is followed by "command not found"...
Code:
sudo cfdisk /dev/hda
- the same FATAL ERROR,
but returns "Opened disk read-only - you have no permission to write"
Could that be the cause?
May be I indeed need to try 3.4 (though a friend who gave me v.3.3 succedded with that CD)...
Similar Threads
-
By minifat in forum Knoppix DVD
Replies: 3
Last Post: 10-18-2005, 08:51 PM
-
By TaNgO in forum Hdd Install / Debian / Apt
Replies: 3
Last Post: 07-26-2004, 11:16 PM
-
By migross in forum General Support
Replies: 4
Last Post: 10-23-2003, 07:56 AM
-
By phillfri in forum Hardware & Booting
Replies: 3
Last Post: 09-26-2003, 01:52 AM
-
By Mad_Max_FX in forum Hdd Install / Debian / Apt
Replies: 1
Last Post: 06-22-2003, 03:29 AM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

HP ProLiant MicroServer Gen8 G1610T @2.3 GHz, 16GB, 712317-001 NO HDD/OS
$199.00

Nasuni NF-50 Supermicro Server, Atom CPU C2558, @ 2.40GHz, 8GB RAM-No HDD/OS/AC
$250.00

Supermicro CSE-937 3U Storage Chassis No CPU No HDD No Ram Tested & Reset
$129.99

Supermicro 1U Network Server Appliance 16GB RAM 800GB SSD 6 LAN Ports Powers On
$450.00

Supermicro 2U X10DRU-i 2x E5-2680 v3 2.5ghz 32gb Ram 240gb SSD 2x GPU *READ*
$369.99

New Barebones Supermicro 5019D Server, 4C/8T Xeon D-2123T, 1U Rackmountable, 10G
$449.99

Supermicro 5019D-4C-FN8TP Xeon D-2123IT (4C/8T) 64GB DDR4 10GbE 480GB 1U Server
$689.00

1U Edge Firewall Server X11SCW-F Xeon E-2174G 0 RAM M.2 NVME 3x PCI-e 2x PSU X
$175.00

Supermicro 505-2 Server
$280.00

Supermicro CSE-937 3U Storage Chassis No CPU No HDD No Ram Tested & Reset
$129.99