I believe if you issue the command "xhost +localhost" you'll be in business.
For further details check:
man xhost
Unlike my previously successful hard disk Knoppix installations (various versions from 3.1 to 3.4) my latest HD installation (3.8.1) does not result in root being one of the user options for selection once the boot process has finished. I can login as a normal user, and successfully su into root via a terminal window, but if I then try to start Konqueror from the command line I get the following:-
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
konqueror: cannot connect to X server :0.0
How can I run root from a KDE graphical interface using Knoppix 3.8.1, as I am used to doing using Knoppix 3.3?
The rest of the installation works fine, and I am even able to print from a network printer which previously required editing of cups and kde configuration files.
Thanks for any advice.
I believe if you issue the command "xhost +localhost" you'll be in business.
For further details check:
man xhost
Thanks for the reply eon. Unfortunately, although the command you suggested works for localhost, it doesn't work for root for some reason. Below is some more output that may be useful for someone to explain what I need to adjust to enable a graphical root environment.
mark@z:~$ xhost + localhost
localhost being added to access control list
root@z:/home/mark# xhost + root
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
xhost: unable to open display ":0.0"
root@z:/home/mark# startx
xauth: creating new authority file /root/.Xauthority
xauth: creating new authority file /root/.Xauthority
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority
X: warning; process set to priority -11 instead of requested priority -10
Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.
When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
Please report problems to [email protected].
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
giving up.
xinit: unable to connect to X server
xinit: No such process (errno 3): Server error.
You might want to check this thread: http://www.linuxforums.org/forum/topic-19634.html
And look at ~/.xinitrc file to see what's there or not there.
Check here, too: http://www.knoppix.net/forum/viewtop...?p=82492#82492
-- Ed
And another link: http://www.knoppix.net/forum/viewtopic.php?t=17347
There's plenty about this on this site if you search.

SFP TO RJ45 TRANSCEIVER SFP MODULE COPPER SFP OPTICAL PORT TO RJ45 ETHERNET PORT
$7.99
NEW Sealed Cisco SFP-10G-LR 10GBASE-LR SFP+ 1310nm 10km *US Shipping*
$24.00
Intel SPTSLP2SLCDE 100G-DR1 QSFP28 500m 1311nm Transceivers - Lot of 10 - New
$200.00
Cisco QSFP-40G-SR-BD Module 10-2945-02 NEW CLAMSHELL
$45.50
Genuine Cisco SFP-10G-SR 0-2415-03 10 Gigabit Transceiver
$5.40
HP 560SFP+ 10GB 2-port PCIe NIC Ethernet ADAPTER 669279-001 w/ (2) 10GB SFP+
$16.99
ProLabs SFP-10G-SR-C 10GBASE SR SFP+ MMF 850NM MMF RoHS Class 1 Laser
$15.00
Intel X520-DA2 10Gb 10Gbe 10 Gigabit Network Adapter NIC Dual Port E10G42BTDA
$28.94
New Sealed Cisco GLC-LH-SMD 1000BASE-LX/LH SFP Transceiver Module *US
$17.00
Dell Intel X710-DA2 5N7Y5 Dual-Port 10GbE SFP+ PCIe 3.0 x8 Network Adapter
$27.50