I had an older version of knoppix (not sure what release or date, could been 3.0).
This version of knoppix (3.2 apr18) is unable to use sftp:// access in kde's file manager. From what I've traced on the server side, it appears that the client stops and silently disconnects after it connects and authenticates. From here, the client stalls for almost a minute. it appears that sshd (or ssh-ftp) tries to read the buffer, and the client never supplies any data and disconnects. The actual error message is:
An error occured while loading sftp://[email protected]/home/supaplex/:
Could not connect to host localhost.
also, armada.pcbkits.com is in the /etc/hosts file (same error occurs when I use the ip address alone). This error occurs on the live cd and on the hd install. I've not been able to get this version to work on any host in any situation.
command line utilities like scp, sftp and ssh work as expected.
Any help would be appriciated. Thanks.

New Barebones Supermicro 5019D Server, 4C/8T Xeon D-2123T, 1U Rackmountable, 10G
$449.99
$280.00
1U Edge Firewall Server X11SCW-F Xeon E-2174G 0 RAM M.2 NVME 3x PCI-e 2x PSU X
$175.00
Supermicro 1U Network Server Appliance 16GB RAM 800GB SSD 6 LAN Ports Powers On
$450.00
Supermicro SuperServer E300-15 - SYS-e300-9C - 16GB RAM 240GB Samsung SSD
$239.00
Supermicro 2U X10DRU-i 2x E5-2680 v3 2.5ghz 32gb Ram 240gb SSD 2x GPU *READ*
$369.99
SuperMicro 4U CSE 847 36 Bay LFF Barebone 2x 1280W w/ 2x Bays 2.5 Rear w/Trays
$499.99
Supermicro 5019D-4C-FN8TP Xeon D-2123IT (4C/8T) 64GB DDR4 10GbE 480GB 1U Server
$689.00
Supermicro CSE-937 3U Storage Chassis No CPU No HDD No Ram Tested & Reset
$129.99
Supermicro 938-16 16-LFF MicroCloud SuperServer 5038MR-H8TRF *No Blade Servers*
$159.99