Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: SOLVED [KDE 3.5.3 fails loading desktop]

Hybrid View

  1. #1
    Senior Member registered user
    Join Date
    Apr 2004
    Location
    Finland
    Posts
    272

    SOLVED [KDE 3.5.3 fails loading desktop]

    Everything has worked fine in my remasterings but now I got a problem. Dist-upgrading from KDE 3.5.2 to KDE 3.5.3 removed kdelibs-bin and now KDE starts but fails in loading destkop. I'm not sure if there is coming any kdelibs-bin package to unstable - I think that kdelibs is replacement for it. What to do?

    -tapsa-

  2. #2
    Senior Member registered user
    Join Date
    Apr 2004
    Location
    Finland
    Posts
    272
    I still can't get KDE to go forward after Loading Desktop. Could there be some changes in 3.5.3's startup process so that /etc/X11/Xsession.d/45xsession can't start KDE anymore? At least in page http://www.kde.org/announcements/cha...5_2to3_5_3.php is mentioned of kdebase:
    Code:
    New: KDE startup reordered in order to improve startup time.
    How to get 45xsession fixed so that init 5 starts KDE?

    -tapsa-

  3. #3
    Senior Member registered user
    Join Date
    Jun 2003
    Location
    Piraeus / Hellas
    Posts
    121
    Dear Tr,

    I suffer from the same "kind" of problem. I have older version of knoppix installed at my Hard Disk and after last apt-get upgrade the "loading" of the KDE stopped at Loading Desktop and if you wait 2-3 minutes you will see only the wallpaper of the screen nothing more...

    Did you find any solution may be related to 45Xsession file???

    What do you think??

    Best Regards,
    Mike Kranidis

  4. #4
    Senior Member registered user
    Join Date
    Apr 2004
    Location
    Finland
    Posts
    272
    Quote Originally Posted by mikekgr
    Did you find any solution may be related to 45Xsession file???
    Yes, this must be 45xsession problem, see http://lists.debian.org/debian-knopp.../msg00068.html
    I don't know how to fix this, yet

    -tapsa-

  5. #5
    Senior Member registered user
    Join Date
    Jun 2003
    Location
    Piraeus / Hellas
    Posts
    121
    thanks a lot.
    Please if you find the solution let me knows.... for the time being I reverted a recent backup so I have 3.5.2 at least

    Bye

  6. #6
    Senior Member registered user
    Join Date
    Jun 2003
    Location
    Piraeus / Hellas
    Posts
    121
    Dear tapsa,

    did you found any solution on the above mentioned problem????

    Anybody else found a solution???

    Please help
    \

  7. #7
    Senior Member registered user
    Join Date
    Apr 2004
    Location
    Finland
    Posts
    272
    Quote Originally Posted by mikekgr
    did you found any solution on the above mentioned problem????
    Sorry, I have not. Perhaps we need to wait until Mr. Knopper or Kano makes a new release. I don't even be sure any more if this is a 45xsession problem or KDE bug.

    According to my experience there's also problems with new 2.6.17 kernel. My old 2.6.16. kernel works fine but with 2.6.17 kernel ndiswrapper don't work. So peculiar as it looks like, I also have problems starting dcopserver - with new 2.6.17 kernel (having in same DVD two bootable kernels) Nothing wrong with my old kernel http://tapsa.terae.net/linux/knoppix....16-beyond4.1/

    -tapsa-

  8. #8
    Junior Member
    Join Date
    Jul 2006
    Posts
    1

    Hypothesis

    Hello everybody,

    I've been playing around, and I think the problem lies in the definition of the environment variable LD_BIND_NOW within the '/etc/X11/Xsession.d/45xsession' script, which should be now exactly defined as in the '/usr/bin/startkde' script. I haven't test it yet though.

    Regards,

    Pablo

  9. #9
    Senior Member registered user
    Join Date
    Jun 2003
    Location
    Piraeus / Hellas
    Posts
    121
    Dear Palvarado,
    thanks a lot for the suggestion.
    Because I am not linux guru, only user here, how can solve the problem follows your suggestion???

    Best Regards
    Mike Kranidis

  10. #10
    Senior Member registered user
    Join Date
    Apr 2004
    Location
    Finland
    Posts
    272

    Solved [Re: Hypothesis]

    Quote Originally Posted by Palvarado
    I've been playing around, and I think the problem lies in the definition of the environment variable LD_BIND_NOW within the '/etc/X11/Xsession.d/45xsession' script, which should be now exactly defined as in the '/usr/bin/startkde' script. I haven't test it yet though.
    Hi Palvarado, you did it! This really works!

    To those who don't understand what to do, I try to explain this as clearly as possibly. You must change the following portion in
    /etc/X11/Xsession.d/45xsession file
    from:
    Code:
    # kdeinit unsets this variable before loading applications.
     LD_BIND_NOW=true kdeinit +kcminit || \
     { xmessage -geometry 500x100 "Could not start kdeinit. Check your installation"; return 1; }
    to:
    Code:
    # kdeinit unsets this variable before loading applications.
    LD_BIND_NOW=true kdeinit --new-startup +kcminit_startup
    if test $? -ne 0; then
      # Startup error
      echo 'startkde: Could not start kdeinit. Check your installation.'  1>&2
      xmessage -geometry 500x100 "Could not start kdeinit. Check your installation."
    fi
    -tapsa-

Page 1 of 2 12 LastLast

Similar Threads

  1. PXE Boot fails while loading Vmlinuz
    By Masiaka in forum Networking
    Replies: 2
    Last Post: 03-12-2008, 06:35 AM
  2. 5.1 HAS MOUSE BUT CANT GET PASS DESKTOP LOADING
    By beech1 in forum Hardware & Booting
    Replies: 4
    Last Post: 01-02-2008, 08:25 PM
  3. kde-3.5.1 installed -desktop dont allow picures [solved]
    By ramaswamyps in forum Hdd Install / Debian / Apt
    Replies: 8
    Last Post: 03-19-2006, 06:57 PM
  4. ataraid fails
    By dtlin in forum Hardware & Booting
    Replies: 0
    Last Post: 12-12-2003, 12:26 PM
  5. Nessus fails
    By blase in forum General Support
    Replies: 3
    Last Post: 01-20-2003, 06:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


HP PROLIANT  TPS-W003 MICRO- SERVER TOWER Gen 8, 16G RAM picture

HP PROLIANT TPS-W003 MICRO- SERVER TOWER Gen 8, 16G RAM

$195.00



HP ProLiant MicroServer Gen8 G1610T @2.3 GHz, 16GB, 712317-001 NO HDD/OS picture

HP ProLiant MicroServer Gen8 G1610T @2.3 GHz, 16GB, 712317-001 NO HDD/OS

$199.00



Supermicro 1U Network Server Appliance 16GB RAM 800GB SSD 6 LAN Ports Powers On picture

Supermicro 1U Network Server Appliance 16GB RAM 800GB SSD 6 LAN Ports Powers On

$450.00



Supermicro 505-2   Server picture

Supermicro 505-2 Server

$280.00



Supermicro E200-8D Mini Server Xeon D-1528 6-Core 64GB ECC 1TB SSD 2x10GbE IPMI picture

Supermicro E200-8D Mini Server Xeon D-1528 6-Core 64GB ECC 1TB SSD 2x10GbE IPMI

$525.00



HP PROLIANT MICROSERVER GEN8 E3-1220LV2 @ 2.30GHz, 8GB RAM, NO HDD/OS picture

HP PROLIANT MICROSERVER GEN8 E3-1220LV2 @ 2.30GHz, 8GB RAM, NO HDD/OS

$164.97



SUPERMICRO CSE-836 XEON E5-1620 v3 @ 3.50GHz, 32GB RAM, NO HDD/OS picture

SUPERMICRO CSE-836 XEON E5-1620 v3 @ 3.50GHz, 32GB RAM, NO HDD/OS

$299.99



Supermicro 1027GR-TSF 1U Rackmount Server 2x Xeon 2.3GHz 128GB DDR3 picture

Supermicro 1027GR-TSF 1U Rackmount Server 2x Xeon 2.3GHz 128GB DDR3

$219.99



Supermicro CSE-937 3U Storage Chassis No CPU No HDD No Ram Tested & Reset picture

Supermicro CSE-937 3U Storage Chassis No CPU No HDD No Ram Tested & Reset

$129.99



Nasuni NF-50 Supermicro Server, Atom CPU C2558, @ 2.40GHz, 8GB RAM-No HDD/OS/AC picture

Nasuni NF-50 Supermicro Server, Atom CPU C2558, @ 2.40GHz, 8GB RAM-No HDD/OS/AC

$187.50