-
Knoppix 5.0.1 printing from command line
Hi all,
I have been googleing a lot around this, but found no solution or valuable hint to understand.
I need to configure and run a printer, using cups, all this from the command line.
I have successfully configured the queue with foomatic-configure (after fixing the database with foomatic-cleanup-drivers), then I use lpr to send a job to the printer. No printing starts! I enabled cups debug verbosity in the logs and figured out I have a problem writing to /var/spool/cups/tmp. This looks coherent with the permission/ownership scheme of /var/spool/cups which is :
drwx--x--- 4 root lpadmin
Since I run the server as user "lp" and group "lpadmin" (I think this is default, but I also tryed to force this setting in /etc/cups/cupsd.conf), when the filter calls "gs" as user "lp" this program is unable to access /var/spool/cups/tmp.
BTW I can succesfully print if I hack /var/spool/cups permission or if I run cupsd as root, but this doesn't sound a good solution so I ask if anyone can tell me the right way to fix it.
I also found a different suggestion for spool dir permission scheme, but I'm not sure if it apply to cups 1.1.23 (the one shipped with my Knoppix 5.0.1) at http://www.linuxprinting.org/error_log-faq.html#q_3_9. This should work for the situation but drwx--x--- is default in knoppix (and even on my Ubuntu 6.06 box). The permission/ownership also seem to be "reset" every time I restart the server, so hacking it sounds again more dirty.
TIA for any suggestion!
Andrea
-
Junior Member
registered user
Thanks for posting your progress on this , cups is badly broken in 5.0.1 and it seems like your efforts have gone a long way to finding the problem.
if it helps I have 1.2.5 on a gentoo box and the perms are the same as you posted for knoppix, this seems fairly standard.
If you get any further pls post results. I'm sure a lot of ppl would like to have printing working.
-

Originally Posted by
knoppu
Thanks for posting your progress on this , cups is badly broken in 5.0.1 and it seems like your efforts have gone a long way to finding the problem.
Thx knoppu for your reply. This post was for probing if I'm struggling with something known or maybe an interesting to solve problem. Since I'm doing a custom remaster where I really need a working printing engine, I'm interested in gathering as much info as possible about this problem. You say cups is broken in 5.0.1. Do you have any resource telling what the problem are to point me to?

Originally Posted by
knoppu
if it helps I have 1.2.5 on a gentoo box and the perms are the same as you posted for knoppix, this seems fairly standard.
So this could be a point to start from.

Originally Posted by
knoppu
If you get any further pls post results. I'm sure a lot of ppl would like to have printing working.

I'll stay tuned and post any improvement if I get any
Regards,
Andrea
-
Junior Member
registered user
http://www.knoppix.net/wiki/Bugs/5.01CD bug 5
this confirms my experience that everything cups related in 5 is broken.
It makes reference to the french forum but that was so damn slow I got tired of waiting 2min on every click and gave up. I saw one post http://forums.knoppix-fr.org/viewtopic.php?id=11422 that says he fixed it but I gave up looking for the thread where he posted about that.
In case you dont speak french you could try googling the forum for his user id and "imprimante" = printer, and get google to translate.
If you find something but cant read it post me a link.

PS
http://forums.knoppix-fr.org/viewtopic.php?id=11328
Lancer Kprinter
Attendre le message d'erreur et repondre OK
Puis dans la fenetre kprinter cliquer sur "Options Système" puis choisir dans l'ascenseur a Gauche "Serveur Cups" et remplacer le contenu du champs Hôte "/var/run/cups/cups.lock" par "localhost"
Et hop !
Seems to be a problem with kprinter but if you boot knoppix to kde maybe it is doing something with this lock file which is enough to block cups command line as well. You should be able to pick the nuts out of that little bit.
HTH
-
I'm new to knoppix and having a problem on printing also, i've red all the answers about printing problems but seems to be too advance already for me. my problem is that my printer was not even detected by the system, i'm using knoppix 5.0.1 and my printer is hp deskjet 3550.I go to control center, click on printers and Error- control center. unable to retreive the printer list, error message received from manager. Connedtion to CUPS server failed.... connection failed. What does this mean? Please help, i'm beggining to love linux and i want to learn more. thanks in advance
rl60hz
-
For anyone having problems printing in Knoppix 5.0.1, I had the same problem at first. The following worked for me, and is different from my previous version of knoppix.
K -> knoppix -> configure -> configure printers
Add Printer
Local Printer
appropriate port (parallel port in my case)
I selected the ESP driver for my printer (most of the drivers don't seem to be there).
The missing drivers is what threw me off at first. Please let everyone know if this helps you or not.
-
Senior Member
registered user
rl60hz, open a root shell and type: cupsd
That should start the printing service, however there are bugs as the other posters here suggest.
Similar Threads
-
By Mongoose in forum MS Windows & New to Linux
Replies: 2
Last Post: 06-07-2006, 12:23 AM
-
By chaosnine in forum Customising & Remastering
Replies: 1
Last Post: 08-17-2005, 07:35 PM
-
By TyIsOwned in forum Hardware & Booting
Replies: 1
Last Post: 07-27-2005, 02:18 PM
-
By Jesse in forum Hdd Install / Debian / Apt
Replies: 8
Last Post: 04-30-2004, 05:57 PM
-
By snake001 in forum General Support
Replies: 2
Last Post: 11-01-2003, 11:29 AM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

Supermicro 2U X10DRU-i 2x E5-2680 v3 2.5ghz 32gb Ram 240gb SSD 2x GPU *READ*
$369.99

HP ProLiant MicroServer Gen8 G1610T @2.3 GHz, 16GB, 712317-001 NO HDD/OS
$199.00

Supermicro CSE-937 3U Storage Chassis No CPU No HDD No Ram Tested & Reset
$129.99

Supermicro 1U Network Server Appliance 16GB RAM 800GB SSD 6 LAN Ports Powers On
$450.00

New Barebones Supermicro 5019D Server, 4C/8T Xeon D-2123T, 1U Rackmountable, 10G
$449.99

Supermicro SYS-E302-9A Fanless Firewall Atom C3558 16GB ECC 64GB SSD 6x GbE i350
$325.00

Supermicro 5019D-4C-FN8TP Xeon D-2123IT (4C/8T) 64GB DDR4 10GbE 480GB 1U Server
$689.00

Supermicro 1027GR-TSF 1U Rackmount Server 2x Xeon 2.3GHz 128GB DDR3
$219.99

Nasuni NF-50 Supermicro Server, Atom CPU C2558, @ 2.40GHz, 8GB RAM-No HDD/OS/AC
$250.00

Supermicro 505-2 Server
$280.00