Results 1 to 3 of 3

Thread: PXE Boot fails while loading Vmlinuz

  1. #1
    Junior Member
    Join Date
    Mar 2008
    Posts
    4

    PXE Boot fails while loading Vmlinuz

    I've chose all the default settings when loading up the the openmosix terminal server and my etherboot works good. I get a message shortly after loading, something kinda like:

    loading vmlinuz.........
    Boot failed. Insert another disc and press return to continue.

    I've read this could be a multitude of problems, one of them being that this kernel may not support the drivers my machine needs to load. There could also be a lot of directory problems too, which I don't really understand. Is this the same kernel that comes with Knoppix? I can run Knoppix just great it if I pop the live cd in but it really doesn't want to finish loading vmlinuz. Is this a bug? Where should I go from here?

  2. #2
    Junior Member registered user
    Join Date
    Apr 2005
    Posts
    10
    Which knoppix version did you take?

    Older versions worked fine, while the latest knoppix 5.3 ends in Kernel Panik when trying to mount root fs
    Booting in verbose mode shows that the kernel has tried to mount root as raiser, ext, fat, iso,... filesystem. But to get pxe-boot working afaik another kernel is needed. It should be one with ip-kernellevel-autoconfiguration, root-over-nfs and some other spezial kernel-features activated. One can take a brief look on /tftpboot/vmlinuz and /boot/vmlinuz-2.6.24, same filessize... Seems like someone made a mistake when packaging knoppix 5.3 dvd

    well, to get it working, i think we have to compile our own nfs-root-capable kernel, at least until 5.3.1, (or use older version)

  3. #3
    Junior Member
    Join Date
    Mar 2008
    Posts
    4

    clusterKnoppix 3.6 broken

    After consulting my professor, we are both in strong agreement that ClusterKnoppix verson 3.6 has some serious inconsistencies that make a lot of stuff not work.

    We've traced the IPSec problem down to the fact that theres a .conf file that points to where IPSec should be and where its tools are, yet they are placed in an entirely different folder, specifically the /KNOPPIX folder.

    It stands to reason that this kernel issue could very well be. Indeed if you try to boot a Chaos node from this version of the distro from PXE, it will flat out tell you it cannot find the kernel. Again, the .conf file written for pxelinux points do the /diskless directory for it to find the kernel, but it appears to reside somewhere else completely. I'm not a linux pro or else I would have moved the files accordingly.

    If anyone else can get their hands on clusterKnoppix 3.6 and take a look at it to verify this for me, I would be greatful. Even though clusterKnoppix is pretty much a dead project, I may be able to find someone interested in at least fixing it. In the future, though, I'll most likely roll my own and add openmosix to it.

Similar Threads

  1. SOLVED [KDE 3.5.3 fails loading desktop]
    By tr in forum Customising & Remastering
    Replies: 15
    Last Post: 09-10-2006, 07:33 PM
  2. CD Boot works, HDD Installed boot fails at second hurdle
    By Rib in forum Hdd Install / Debian / Apt
    Replies: 0
    Last Post: 08-07-2004, 12:43 PM
  3. ash and vmlinuz
    By TyphoonMentat in forum Customising & Remastering
    Replies: 0
    Last Post: 08-04-2004, 09:19 AM
  4. Boot fails after decompressing vmlinuz and miniroot
    By istvan43 in forum General Support
    Replies: 0
    Last Post: 03-06-2004, 07:32 PM
  5. how to use vmlinuz-2.4.19_xfs with scsi harddisk loading
    By narendar in forum Hdd Install / Debian / Apt
    Replies: 2
    Last Post: 04-04-2003, 05:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Genuine Cisco SFP-10G-SR 0-2415-03 10 Gigabit Transceiver picture

Genuine Cisco SFP-10G-SR 0-2415-03 10 Gigabit Transceiver

$5.40



NEW Sealed Cisco SFP-10G-LR 10GBASE-LR SFP+ 1310nm 10km *US Shipping* picture

NEW Sealed Cisco SFP-10G-LR 10GBASE-LR SFP+ 1310nm 10km *US Shipping*

$24.00



CISCO 10GBASE-SR SFP

CISCO 10GBASE-SR SFP "Lot of 4” SFP-10G-SR

$47.99



Cisco Acacia DP04QSDD-E25-840 400G QSFP-DD Coherent DCO Transceiver Module picture

Cisco Acacia DP04QSDD-E25-840 400G QSFP-DD Coherent DCO Transceiver Module

$699.99



SFP TO RJ45 TRANSCEIVER SFP MODULE COPPER SFP OPTICAL PORT TO RJ45 ETHERNET PORT picture

SFP TO RJ45 TRANSCEIVER SFP MODULE COPPER SFP OPTICAL PORT TO RJ45 ETHERNET PORT

$7.99



Intel X520-DA2 10Gb 10Gbe 10 Gigabit Network Adapter NIC Dual Port E10G42BTDA picture

Intel X520-DA2 10Gb 10Gbe 10 Gigabit Network Adapter NIC Dual Port E10G42BTDA

$28.94



HP 560SFP+ 10GB 2-port  PCIe NIC Ethernet ADAPTER 669279-001 w/ (2) 10GB SFP+ picture

HP 560SFP+ 10GB 2-port PCIe NIC Ethernet ADAPTER 669279-001 w/ (2) 10GB SFP+

$16.99



Lot of 2 Cisco 10-3107-01 SFP-10G-LR-S S-Class SFP+ 10G LR SMF LC Transceiver picture

Lot of 2 Cisco 10-3107-01 SFP-10G-LR-S S-Class SFP+ 10G LR SMF LC Transceiver

$59.95



Dell 10 Gigabit SFP+ SR Transceiver 0XYD50 NEW SEALED picture

Dell 10 Gigabit SFP+ SR Transceiver 0XYD50 NEW SEALED

$24.99



Cisco WS-C3650-12X48UR-L 48-Port Stackable Layer 3 8x10G SFP+ Port Switch picture

Cisco WS-C3650-12X48UR-L 48-Port Stackable Layer 3 8x10G SFP+ Port Switch

$129.99