That is the last message but what about other messages like can the script linuxrc find your clooped image and mount it etc.

INIT not found just mean that when the linuxrc exit, the kernel will proceed to use the new root system and search for /etc/init to run and failed. So the most likely cause(as KNOPPIX doesn't not switch real root device) would be that it failed to mount the image does the KNOPPIX fs is not 'imported' in.

More messages are needed.