-
Hi szzsqing1
Yes I got the same message when replacing Libreoffice with Openoffice, see my post:
http://www.knoppix.net/forum/threads...reOffice-3.3.3
I got rid of the error message, [which would come up again each time I tried to install any other software using synaptic or aptitude] by simply uninstalling postgresql8.4 and postgresql-common [and maybe a couple of other related installed packeges that came up in a synaptic search for postresql packages].
This seems to leave Openoffice [and all the other programmes that I use] still perfectly functional - but of course it might mess up something else you needed to run [but which i don't use]. So far it hasn't bothered me.
So that is a possible fix but definitely not an elegant one. I wonder if it is due to there being later versions of postgresql in the synaptic package list, v9.0 and v9.1 and perhaps the new Libreoffice prefers to work with one of them rather than with v8.4 [the installed version with knoppix 6.7.1] - but this is only a guess.
Best wishes, John
-
This "clash" with postgresql-common remains in KX7.0. Installing any language package for LO triggers an upgrade of all the LO components already installed. In my case, attempting to add the en-GB pack triggered an upgrade for LibreOffice, which in turn required an upgrade of python-uno and this triggered a re-setup of postgresql-common.
What appears to be happening is that as part of the configuration of postgresql-common by dpkg, a request to start the PostgreSQL-8.4 database server is made and this start process fails.
The consequent failure of the python-uno upgrade left a ".lock" file in place. Running "sudo apt-get -f install" after removing the lock file fixed most of the python-uno upgrade, except for the situation in postgresql-common.
Setting up postgresql-common (113) ...
Starting PostgreSQL 8.4 database server: mainThe PostgreSQL server failed to start. Please check the log output: 2012-04-11 22:12:12 BST FATAL: konnte Serverzertifikatsdatei >>server.crt<< nicht laden: Datei oder Verzeichnis nicht ge ... failed!
failed!
invoke-rc.d: initscript postgresql, action "start" failed.
dpkg: error processing postgresql-common (--configure):
subprocess installed post-installation script returned error exit status 1
configured to not write apport reports
Errors were encountered while processing:
postgresql-common
E: Sub-process /usr/bin/dpkg returned an error code (1)
The queston is ...why is dpkg requesting the database server to start? Is the server required in order for dpkg toconfigure an upgrade? If not, why the call?
I fixed the situation by removing postgresql-8.4 via apt-get, then running "sudo apt-get -f install" to clean up. That reported postgresql-common as suitable for autoremove, which I also ran.
Now both the LO language and help packages for en-GB went straight in, as did myspell-en-gb ... although I had to use "-t testing" to get the latest version of the dictionary.
No problems yet found from the removal of PostgreSQL. Any information as to whether I have put anything else at risk by this removal would be appreciated.
Tags for this Thread
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

Vintage Intel Mainframe Server MCM CPU Substrate Lot Prototyping PGA Validation
$500.00

HP 13210-60001 Disc Drive Interface PCB HP 7900A 7901A Vintage
$225.61

HP 5060-8359 8K Semiconductor Memory Module 5080-9747 Vintage HP Computer
$224.72

Vintage Telex 952003-112 Mechanical Terminal Keyboard IBM 3270 Mainframe DB25
$799.00

Commodore 64 PC with Model 1541 Diskette Drive and Flight Simulator II *READ*
$199.99

Vtg IBM Mainframe Prototype Chip Module Lot 146 pc 1988-1993 ES/9000 Lab Arcive
$649.00

Vintage Mainframe Computer Disk Drive Pack Dyson SMD 5 Level Disks
$79.00

Rare Vintage Mainframe Burroughs Discrete-Transistor Cordwood Module B2500/B5000
$99.95

Vintage UNIVAC 3620670-01 Mainframe Logic Board 15MHz Sperry Computer PCB
$98.95

IBM 3274-51C Controller 3270 mainframe 8" floppy tested to power on
$500.00