Looks like dma is killing you. It's on by default and can be changed in /etc/init.d/bootmisc.sh. Boot the Knoppix cd, mount your /root partition and edit the file.
KNOPPIX 3.3-2003-11-19 downloaded OK and its MD5 checked OK
I had installed 3.2 on hard drive earlier and it works perfectly so I used
the same installation instructions with 3.3. The installation ran perfectly.
3.3's boot seems normal until it suddenly stops with this message on the monitor:
Cleaning: /tmp /vat/lock /var/run 4095Mb
blk: queue c0334b60,I/O limit (mask 0xffffffff)
blk: queue c0334ca8, I/O limit (mask 0xffffffff)
hda: dma_intr: status=0x51 {DriveReady SeekCompleteError}
hda: dma_intr: error=0x84 {DriveStatusError Bad CRC}
hda: dma_intr: status=0x51 {DriveReady SeekCompleteError}
hda: dma_intr: error=0x84 {DriveStatusError Bad CRC}
hda: dma_intr: status=0x51 {DriveReady SeekCompleteError}
hda: dma_intr: error=0x84 {DriveStatusError Bad CRC}
hda: dma_intr: status=0x51 {DriveReady SeekCompleteError}
hda: dma_intr: error=0x84 {DriveStatusError Bad CRC}
The keyboard has no effect----the system is locked (with a blinking
cursor). I have to do a pushbutton restart..
Any clues?
Looks like dma is killing you. It's on by default and can be changed in /etc/init.d/bootmisc.sh. Boot the Knoppix cd, mount your /root partition and edit the file.
My image CD had some missing files---I burned a new one using different
software and this one works OK.
When I ran the CD version, it seemed to work OK.
Thanks.
Thanks for the DMA info. I checked out /etc/init.d/bootmisc.sh and it reads
# enable DMA
/sbin/hdparm -qd1 /dev/hda
/sbin/hdparm -qd1 /dev/hdb
I have no idea if this is OK as is or if it has to be changed.
I've just discovered that there's more to this problem that deserves a new posting..... look for 'Crazy booting"
well mine locked up as well (but i don't remember any dma messages). I fixed it by installing GRUB - YMMV.
Thanks to rickenbacherus's suggestion, I edited /etc/init.d/bootmisc.sh thusly
# enable DMA
# /sbin/hdparm -qd1 /dev/hda
# /sbin/hdparm -qd1 /dev/hdb
and now 3.3 boots up properly using 3.3's LILO
Before I did this, I tried booting 3.3 with a Progeny Debian installer floppy and it also booted properly so apparently, it was some disagreement between the 3.3's LILO and DMA.
I have since changed to boot with GRUB and it boots OK.
Thanks all for the assistance.
You probably just need to edit the dma out of the lilo.conf on the append line.

Vintage Intel Mainframe Server MCM CPU Substrate Lot Prototyping PGA Validation
$500.00
HP 5060-8359 8K Semiconductor Memory Module 5080-9747 Vintage HP Computer
$224.72
HP 13210-60001 Disc Drive Interface PCB HP 7900A 7901A Vintage
$225.61
Vintage Telex 952003-112 Mechanical Terminal Keyboard IBM 3270 Mainframe DB25
$799.00
Vtg IBM Mainframe Prototype Chip Module Lot 146 pc 1988-1993 ES/9000 Lab Arcive
$649.00
Commodore 64 PC with Model 1541 Diskette Drive and Flight Simulator II *READ*
$199.99
Vintage Mainframe Computer Disk Drive Pack Dyson SMD 5 Level Disks
$79.00
Rare Vintage Mainframe Burroughs Discrete-Transistor Cordwood Module B2500/B5000
$99.95
Vintage UNIVAC 3620670-01 Mainframe Logic Board 15MHz Sperry Computer PCB
$98.95
IBM 3274-51C Controller 3270 mainframe 8" floppy tested to power on
$500.00