-
Need Help! - Startx from boot ?
Hello everyone,
I'm using Knoppix to make old pc's and laptops into linux thin terminals which will launch an ICA session.
Here's my problem:
I need the distro installed on the HD to boot directly to a Xsession which will automatically start "wfica" <-- Citrix ICA Linux client
So in essence the machine will look just like a thin terminal.
I have been clawing at this beast for hours trying to figure out this seemingly simple issue. A display manger seem to need to prompt for a login, however I can't allow any kind of linux login prompt because there's already too much things for the user to do. I editect xinitrc to automatically run /usr/lib/ICAClient/wfica . So when I type in "startx" after logging in as root I get the boot to Citrix client look. Which is exactly what I want.
However to get that far I have to log in as root
. I need the distro to simply load up and go directly to launching the /usr/lib/ICAClient/wfica binary. I've tried adding /usr/X11R6/bin/startx to the inittab in which case I get a ton of errors. The X server starts but then errors with an "ApplicationServer" not defined or something like that. However after the computer loads and I login as root, I can run startx just fine?
It looks to me like the system doesn't know where the files are, I went ahead and exported a bunch of directories as a test and I got a different set of errors, but it looked like it was partially resolved, but the Xserver still crashed cause of the errors.
Does anyone have an idea of how to get 'startx' to run upon boot without the massive errors?
I played a bit with kdm but I had an error about "wmaker" file could not be opened, and I have the "wmaker" package installed! (I believe I was trying to run icewm as the desktop manager)
I tried adding "local" to /etc/init.d/ with an entry of "exec /usr/X11R6/bin/startx" to no avail as I read up that Debian uses that file as opposed to rc.local
(I'm a Debian noob b.t.w)
Thanks for any help you guys can provide, hopefully by tomarrow!
--j2
-
Hello again,
Just wanted to let you guys know not to bother with this issue anymore. I finally resolved it by implementing a shell script
--j2
Similar Threads
-
By irena in forum General Support
Replies: 2
Last Post: 09-09-2004, 12:32 PM
-
By tweetyhack in forum General Support
Replies: 0
Last Post: 07-14-2004, 07:41 PM
-
By arkaine23 in forum Customising & Remastering
Replies: 4
Last Post: 08-23-2003, 12:14 PM
-
By john_h in forum Hdd Install / Debian / Apt
Replies: 1
Last Post: 06-25-2003, 09:27 PM
-
By Digital Wanker in forum General Support
Replies: 11
Last Post: 05-07-2003, 08:27 PM
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

Computer Photo History Altair 8800 Philco 212 CDC 6600 DEC PDP-8 Apple 1 UNIVAC
$69.99

S-100 Vector Graphic 64K Ram Board (Altair, IMSAI)
$99.95

S-100 Vector Graphic 12K PROM/RAM Board (Altair, IMSAI)
$99.95

Intel 4004IBM Mark 1 UNIVAC Cray-1 Babbage ENIAC Apple 1 Steve Jobs MITS Altair
$50.99

S-100 Bus Handbook Altair 8800 IMSAI 8080 Board Schematics Xitan Pertec Cromemco
$89.99

Vintage Digital Research ZSID 1.4 8" Floppy Disk CP/M Z80 Software S-100 Altair
$69.99

1979 Microprocessor Projects Altair 8800 Intel 8080 KIM-1 COSMAC Elf SWTPC 6800
$59.99

640pg Best of BYTE Magazine 1984 Mac Steve Jobs Altair 8800 IBM 5100 Bob Moog
$85.00

CP/M 86 1.1R 8086 Highmonitor 8 Inch Floppy Diskette 80s IMSAI Altair
$29.99

ALTAIR Bitcoin Mining Solutions PDU IEC SERIES 100-250V 30A/24A Power Distribute
$99.00