Hi
I have the same error after editied miniroot.gz.. I think it comes from cloop.. did you find any solution ?
Hello
I have made a lot of progress customizing knoppix and now I have gnome 2.2 with BlueCurve, XFree4.2.99 and a trimmed size to 384 MB... I created the image file as mentioned in this tutorial http://gnubox.dyndns.org:8080/~sunil/knoppix.php
When I try to boot to knoppix with the 384 MB KNOPPIX file in /dev/hda3/KNOPPIX (ext2 partition), I get this error:
------------------------------------------------------------------
Accessing KNOPPIX CDROM at /dev/hda3...
Starting init process.
INIT: version 2.78-knoppix booting
Activating swap...
Checking root file system...
fsck 1.32 (09-Nov-2002)
fsck.ext2: Is a directory while trying to open /
/:
The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap), the filesystem is corrupt, try to manually repair and reboot.
e2fsck -b 8193 .... <-------This command doesn't make any difference...
CONTROL-D will exit and REBOOT the system:
root@(none):/#
------------------------------------------------------------------
Any ideas?[/url]
Hi
I have the same error after editied miniroot.gz.. I think it comes from cloop.. did you find any solution ?
Did anyone come up w/ a solution for this? If so, what is it?
Thanks,
cesman
I've same problem .I've removed /etc/fstab but nothing happens![]()
i have been recently working with creatin a kernel 2.6.4 for a Live CD.
me and the team of developers im working with experienced a similar problem wen booting from an hard drive install of our new kernel.
we found that the solution was to alter the /etc/fstab.
the line that states about your hard drive may have a 0 1 at the end.
if you change this to 0 0 it may work
i wood have put exactly how it would look but i aint got access to a Linux comp at the mo and cant remeber it off hand
hope my description helps
ryan
Thanks. May be my problem was i've to run knoppix-autoconfig *before* another script, I've done a symlink from /etc/init.d/knoppix-autoconfig to /etc/rcS.d/S00knoppix-autoconfig and now it works fine!
The harddisk init scripts seems to be no the same from CD scripts.

HP ProLiant MicroServer Gen8 G1610T @2.3 GHz, 16GB, 712317-001 NO HDD/OS
$199.00
Supermicro 1U Network Server Appliance 16GB RAM 800GB SSD 6 LAN Ports Powers On
$450.00
Supermicro CSE-937 3U Storage Chassis No CPU No HDD No Ram Tested & Reset
$129.99
Nasuni NF-50 Supermicro Server, Atom CPU C2558, @ 2.40GHz, 8GB RAM-No HDD/OS/AC
$250.00
New Barebones Supermicro 5019D Server, 4C/8T Xeon D-2123T, 1U Rackmountable, 10G
$449.99
Supermicro 2U X10DRU-i 2x E5-2680 v3 2.5ghz 32gb Ram 240gb SSD 2x GPU *READ*
$369.99
Supermicro CSE-815-5 4B LFF Xeon E3-1245v6 16GB DDR4 1x 9361-8i 4x 1TB SATA HDD
$483.99
Supermicro 5019D-4C-FN8TP Xeon D-2123IT (4C/8T) 64GB DDR4 10GbE 480GB 1U Server
$689.00
$280.00
Supermicro CSE-937 3U Storage Chassis No CPU No HDD No Ram Tested & Reset
$129.99