-
This "clash" with postgresql-common remains in KX7.0. Installing any language package for LO triggers an upgrade of all the LO components already installed. In my case, attempting to add the en-GB pack triggered an upgrade for LibreOffice, which in turn required an upgrade of python-uno and this triggered a re-setup of postgresql-common.
What appears to be happening is that as part of the configuration of postgresql-common by dpkg, a request to start the PostgreSQL-8.4 database server is made and this start process fails.
The consequent failure of the python-uno upgrade left a ".lock" file in place. Running "sudo apt-get -f install" after removing the lock file fixed most of the python-uno upgrade, except for the situation in postgresql-common.
Setting up postgresql-common (113) ...
Starting PostgreSQL 8.4 database server: mainThe PostgreSQL server failed to start. Please check the log output: 2012-04-11 22:12:12 BST FATAL: konnte Serverzertifikatsdatei >>server.crt<< nicht laden: Datei oder Verzeichnis nicht ge ... failed!
failed!
invoke-rc.d: initscript postgresql, action "start" failed.
dpkg: error processing postgresql-common (--configure):
subprocess installed post-installation script returned error exit status 1
configured to not write apport reports
Errors were encountered while processing:
postgresql-common
E: Sub-process /usr/bin/dpkg returned an error code (1)
The queston is ...why is dpkg requesting the database server to start? Is the server required in order for dpkg toconfigure an upgrade? If not, why the call?
I fixed the situation by removing postgresql-8.4 via apt-get, then running "sudo apt-get -f install" to clean up. That reported postgresql-common as suitable for autoremove, which I also ran.
Now both the LO language and help packages for en-GB went straight in, as did myspell-en-gb ... although I had to use "-t testing" to get the latest version of the dictionary.
No problems yet found from the removal of PostgreSQL. Any information as to whether I have put anything else at risk by this removal would be appreciated.
Tags for this Thread
Posting Permissions
- You may not post new threads
- You may not post replies
- You may not post attachments
- You may not edit your posts
-
Forum Rules

HP ProLiant MicroServer Gen8 G1610T @2.3 GHz, 16GB, 712317-001 NO HDD/OS
$199.00

Supermicro 1U Network Server Appliance 16GB RAM 800GB SSD 6 LAN Ports Powers On
$450.00

Supermicro CSE-937 3U Storage Chassis No CPU No HDD No Ram Tested & Reset
$129.99

Supermicro E300-12C Mini 1U Barebone X12SCV-LVDS LGA1200 SNK-P0073A4 w/ Adapter
$225.00

HP PROLIANT MICROSERVER GEN8 E3-1220LV2 @ 2.30GHz, 8GB RAM, NO HDD/OS
$164.97

Supermicro 2U X10DRU-i 2x E5-2680 v3 2.5ghz 32gb Ram 240gb SSD 2x GPU *READ*
$369.99

Supermicro E200-8D Mini Server Xeon D-1528 6-Core 64GB ECC 1TB SSD 2x10GbE IPMI
$525.00

New Barebones Supermicro 5019D Server, 4C/8T Xeon D-2123T, 1U Rackmountable, 10G
$449.99

Supermicro 505-2 Server
$280.00

Supermicro CSE-937 3U Storage Chassis No CPU No HDD No Ram Tested & Reset
$129.99